Description:

Reverses the direction of the mesh.

Syntax:
public void Flip(
bool vertexNormals,
bool faceNormals,
bool faceOrientation,
bool ngonsBoundaryDirection
)
Parameters:
  • vertexNormals
  • Type: bool
  • If true, vertex normals will be reversed.
  • faceNormals
  • Type: bool
  • If true, face normals will be reversed.
  • faceOrientation
  • Type: bool
  • If true, face orientations will be reversed.
  • ngonsBoundaryDirection
  • Type: bool
  • If true, ngon boundaries will be reversed
Returns:
Type: void
Available since:
7.0

Description:

Reverses the direction of the mesh.

Syntax:
public void Flip(
bool vertexNormals,
bool faceNormals,
bool faceOrientation
)
Parameters:
  • vertexNormals
  • Type: bool
  • If true, vertex normals will be reversed.
  • faceNormals
  • Type: bool
  • If true, face normals will be reversed.
  • faceOrientation
  • Type: bool
  • If true, face orientations will be reversed.
Returns:
Type: void
Available since:
5.0

Flip method

Class:  Rhino.Geometry.Mesh

Nothing found