Description:

Smooths a mesh by averaging the positions of mesh vertices in a specified region.

Syntax:
public bool Smooth(
double smoothFactor,
bool bXSmooth,
bool bYSmooth,
bool bZSmooth,
bool bFixBoundaries,
SmoothingCoordinateSystem coordinateSystem,
Plane plane
)
Parameters:
  • smoothFactor
  • Type: double
  • The smoothing factor, which controls how much vertices move towards the average of the neighboring vertices.
  • bXSmooth
  • Type: bool
  • When True vertices move in X axis direction.
  • bYSmooth
  • Type: bool
  • When True vertices move in Y axis direction.
  • bZSmooth
  • Type: bool
  • When True vertices move in Z axis direction.
  • bFixBoundaries
  • Type: bool
  • When True vertices along naked edges will not be modified.
  • plane
  • Type: Plane
  • If SmoothingCoordinateSystem.CPlane specified, then the construction plane.
Returns:
Type: bool
True if successful, False otherwise.
Available since:
6.0

Description:

Smooths a mesh by averaging the positions of mesh vertices in a specified region.

Syntax:
public bool Smooth(
double smoothFactor,
bool bXSmooth,
bool bYSmooth,
bool bZSmooth,
bool bFixBoundaries,
SmoothingCoordinateSystem coordinateSystem
)
Parameters:
  • smoothFactor
  • Type: double
  • The smoothing factor, which controls how much vertices move towards the average of the neighboring vertices.
  • bXSmooth
  • Type: bool
  • When True vertices move in X axis direction.
  • bYSmooth
  • Type: bool
  • When True vertices move in Y axis direction.
  • bZSmooth
  • Type: bool
  • When True vertices move in Z axis direction.
  • bFixBoundaries
  • Type: bool
  • When True vertices along naked edges will not be modified.
Returns:
Type: bool
True if successful, False otherwise.
Available since:
6.0

Description:

Smooths a mesh by averaging the positions of mesh vertices in a specified region.

Syntax:
public bool Smooth(
double smoothFactor,
int numSteps,
bool bXSmooth,
bool bYSmooth,
bool bZSmooth,
bool bFixBoundaries,
SmoothingCoordinateSystem coordinateSystem,
Plane plane
)
Parameters:
  • smoothFactor
  • Type: double
  • The smoothing factor, which controls how much vertices move towards the average of the neighboring vertices.
  • numSteps
  • Type: int
  • The number of smoothing iterations.
  • bXSmooth
  • Type: bool
  • When True vertices move in X axis direction.
  • bYSmooth
  • Type: bool
  • When True vertices move in Y axis direction.
  • bZSmooth
  • Type: bool
  • When True vertices move in Z axis direction.
  • bFixBoundaries
  • Type: bool
  • When True vertices along naked edges will not be modified.
  • plane
  • Type: Plane
  • If SmoothingCoordinateSystem.CPlane specified, then the construction plane.
Returns:
Type: bool
True if successful, False otherwise.
Available since:
8.0

Description:

Smooths part of a mesh by averaging the positions of mesh vertices in a specified region.

Syntax:
public bool Smooth(
IEnumerable<int> vertexIndices,
double smoothFactor,
bool bXSmooth,
bool bYSmooth,
bool bZSmooth,
bool bFixBoundaries,
SmoothingCoordinateSystem coordinateSystem,
Plane plane
)
Parameters:
  • vertexIndices
  • Type: IEnumerable<int>
  • The mesh vertex indices that specify the part of the mesh to smooth.
  • smoothFactor
  • Type: double
  • The smoothing factor, which controls how much vertices move towards the average of the neighboring vertices.
  • bXSmooth
  • Type: bool
  • When True vertices move in X axis direction.
  • bYSmooth
  • Type: bool
  • When True vertices move in Y axis direction.
  • bZSmooth
  • Type: bool
  • When True vertices move in Z axis direction.
  • bFixBoundaries
  • Type: bool
  • When True vertices along naked edges will not be modified.
  • plane
  • Type: Plane
  • If SmoothingCoordinateSystem.CPlane specified, then the construction plane.
Returns:
Type: bool
True if successful, False otherwise.
Available since:
6.8

Description:

Smooths part of a mesh by averaging the positions of mesh vertices in a specified region.

Syntax:
public bool Smooth(
IEnumerable<int> vertexIndices,
double smoothFactor,
int numSteps,
bool bXSmooth,
bool bYSmooth,
bool bZSmooth,
bool bFixBoundaries,
SmoothingCoordinateSystem coordinateSystem,
Plane plane
)
Parameters:
  • vertexIndices
  • Type: IEnumerable<int>
  • The mesh vertex indices that specify the part of the mesh to smooth.
  • smoothFactor
  • Type: double
  • The smoothing factor, which controls how much vertices move towards the average of the neighboring vertices.
  • numSteps
  • Type: int
  • The number of smoothing iterations.
  • bXSmooth
  • Type: bool
  • When True vertices move in X axis direction.
  • bYSmooth
  • Type: bool
  • When True vertices move in Y axis direction.
  • bZSmooth
  • Type: bool
  • When True vertices move in Z axis direction.
  • bFixBoundaries
  • Type: bool
  • When True vertices along naked edges will not be modified.
  • plane
  • Type: Plane
  • If SmoothingCoordinateSystem.CPlane specified, then the construction plane.
Returns:
Type: bool
True if successful, False otherwise.
Available since:
8.0

Smooth method

Class:  Rhino.Geometry.Mesh

Nothing found