Description:

Allows to obtain unsafe pointers to the underlying unmanaged data structures of the mesh.

Syntax:
public MeshUnsafeLock GetUnsafeLock(
bool writable
)
Parameters:
  • writable
  • Type: bool
  • True if user will need to write onto the structure. False otherwise.
Returns:
A lock that needs to be released.
Remarks:
The lock implements the IDisposable interface, and one call of its IDisposable.Dispose() or ReleaseUnsafeLock will update the data structure as required. This can be achieved with a using statement (Using in Vb.Net).
Available since:
6.0

/
/
/
GetUnsafeLock

GetUnsafeLock method

Class:  Rhino.Geometry.Mesh

Nothing found