Description:

Creates a single mesh face from the given input.

Syntax:
public static Mesh CreateFromPatchSingleFace(
Mesh mesh,
IEnumerable<ComponentIndex> components
)
Parameters:
  • mesh
  • Type: Mesh
  • The input mesh.
  • components
  • Type: IEnumerable<ComponentIndex>
  • An enumeration of component indexes from the input mesh. This can be one following combinations: 1 vertex (MeshVertex or MeshTopologyVertex) and 1 edge (MeshTopologyEdge), 2 edges (MeshTopologyEdge), or 3 vertices (MeshVertex or MeshTopologyVertex).
Returns:
Type: Mesh
A new mesh if successful, None otherwise.
Available since:
8.0

/
/
/
CreateFromPatchSingleFace

CreateFromPatchSingleFace method

Class:  Rhino.Geometry.Mesh

Nothing found