Description:

Returns True if every mesh "edge" has at most two faces.

Syntax:
public bool IsManifold()
Returns:
Type: bool
True if the mesh is manifold, False otherwise.
Available since:
7.6

Description:

Gets a value indicating whether or not the mesh is manifold. A manifold mesh does not have any edge that borders more than two faces.

Syntax:
public bool IsManifold(
bool topologicalTest,
out bool isOriented,
out bool hasBoundary
)
Parameters:
  • topologicalTest
  • Type: bool
  • If true, the query treats coincident vertices as the same.
  • isOriented
  • Type: bool
  • isOriented will be set to True if the mesh is a manifold and adjacent faces have compatible face normals.
  • hasBoundary
  • Type: bool
  • hasBoundary will be set to True if the mesh is a manifold and there is at least one "edge" with no more than one adjacent face.
Returns:
Type: bool
True if every mesh "edge" has at most two adjacent faces.
Available since:
5.0

IsManifold method

Class:  Rhino.Geometry.Mesh

Nothing found