Description:

Constructs new mesh that matches a bounding box.

Syntax:
public static Mesh CreateFromBox(
BoundingBox box,
int xCount,
int yCount,
int zCount
)
Parameters:
  • xCount
  • Type: int
  • Number of faces in x-direction.
  • yCount
  • Type: int
  • Number of faces in y-direction.
  • zCount
  • Type: int
  • Number of faces in z-direction.
Returns:
Type: Mesh
A new brep, or None on failure.
Available since:
5.6

Description:

Constructs new mesh that matches an aligned box.

Syntax:
public static Mesh CreateFromBox(
Box box,
int xCount,
int yCount,
int zCount
)
Parameters:
  • box
  • Type: Box
  • Box to match.
  • xCount
  • Type: int
  • Number of faces in x-direction.
  • yCount
  • Type: int
  • Number of faces in y-direction.
  • zCount
  • Type: int
  • Number of faces in z-direction.
Returns:
Type: Mesh
Available since:
5.3

Description:

Constructs new mesh from 8 corner points.

Syntax:
public static Mesh CreateFromBox(
IEnumerable<Point3d> corners,
int xCount,
int yCount,
int zCount
)
Parameters:
  • corners
  • Type: IEnumerable<Point3d>
  • 8 points defining the box corners arranged as the vN labels indicate.
    v7_____________v6  
    |\             |\  
    | \            | \  
    |  \ _____________\  
    |   v4         |   v5  
    |   |          |   |  
    |   |          |   |  
    v3--|----------v2  |  
     \  |           \  |  
      \ |            \ |  
       \|             \|  
        v0_____________v1
  • xCount
  • Type: int
  • Number of faces in x-direction.
  • yCount
  • Type: int
  • Number of faces in y-direction.
  • zCount
  • Type: int
  • Number of faces in z-direction.
Returns:
Type: Mesh
A new brep, or None on failure.
Available since:
5.3

/
/
/
CreateFromBox

CreateFromBox method

Class:  Rhino.Geometry.Mesh

Nothing found