Description:
Computes the solid difference of two sets of Meshes.
Syntax:
public static Mesh[] CreateBooleanDifference(
IEnumerable<Mesh> firstSet,
IEnumerable<Mesh> secondSet,
MeshBooleanOptions options,
out Result result
)
IEnumerable<Mesh> firstSet,
IEnumerable<Mesh> secondSet,
MeshBooleanOptions options,
out Result result
)
Parameters:
- firstSet
- Type: IEnumerable<Mesh>
- First set of Meshes (the set to subtract from).
- secondSet
- Type: IEnumerable<Mesh>
- Second set of Meshes (the set to subtract).
- options
- Type: MeshBooleanOptions
- An option instance. Should have a valid Tolerance set.
- result
- Type: Commands.Result
- Indicates if the function succeeded, was cancelled, did nothing, or failed.
Returns:
Type: Mesh[]
An array of Mesh results or None on failure.
Available since:
8.0
Description:
Computes the solid difference of two sets of Meshes.
Syntax:
public static Mesh[] CreateBooleanDifference(
IEnumerable<Mesh> firstSet,
IEnumerable<Mesh> secondSet
)
IEnumerable<Mesh> firstSet,
IEnumerable<Mesh> secondSet
)
Parameters:
- firstSet
- Type: IEnumerable<Mesh>
- First set of Meshes (the set to subtract from).
- secondSet
- Type: IEnumerable<Mesh>
- Second set of Meshes (the set to subtract).
Returns:
Type: Mesh[]
An array of Mesh results or None on failure.
Available since:
5.0