Description:

Gets the point on the mesh that is closest to a given test point. Similar to the ClosestPoint function except this returns a MeshPoint class which includes extra information beyond just the location of the closest point.

Syntax:
public MeshPoint ClosestMeshPoint(
Point3d testPoint,
double maximumDistance
)
Parameters:
  • testPoint
  • Type: Point3d
  • The source of the search.
  • maximumDistance
  • Type: double
  • Optional upper bound on the distance from test point to the mesh. If you are only interested in finding a point Q on the mesh when testPoint.DistanceTo(Q) < maximumDistance, then set maximumDistance to that value. This parameter is ignored if you pass 0.0 for a maximumDistance.
Returns:
Type: MeshPoint
closest point information on success. None on failure.
Available since:
5.0

/
/
/
ClosestMeshPoint

ClosestMeshPoint method

Class:  Rhino.Geometry.Mesh

Nothing found