Click or drag to resize

GH_ConvertBackSolveExpression Method

Try and backsolve an expression

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static bool BackSolveExpression(
	string exp,
	string variable,
	double target,
	double minimum,
	double maximum,
	int steps,
	out double t,
	out double v
)

Parameters

exp
Type: SystemString
Expression to back solve.
variable
Type: SystemString
Name of input variable.
target
Type: SystemDouble
Result to look for.
minimum
Type: SystemDouble
Lowest input to try.
maximum
Type: SystemDouble
Highest input to try.
steps
Type: SystemInt32
Number of steps per iteration.
t
Type: SystemDouble
Value for variable that closest approximates the target value.
v
Type: SystemDouble
Value of expression for the best approximation.

Return Value

Type: Boolean
True on success, false on failure..
See Also