Click or drag to resize

GH_ConvertByteArrayToCommonObjectT Method

Convert an OpenNurbs compliant compressed byte array into a RhinoCommon object.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static T ByteArrayToCommonObject<T>(
	byte[] data
)
where T : CommonObject

Parameters

data
Type: SystemByte
Byte array to de-serialize.

Type Parameters

T

Return Value

Type: T
A RhinoCommon object instance or null on failure.
See Also