Click or drag to resize

GH_ConvertToGoo Method

Converts an object into Goo. Does not duplicate the data if a lossless conversion is possible.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static IGH_Goo ToGoo(
	Object data
)

Parameters

data
Type: SystemObject
Data to convert.

Return Value

Type: IGH_Goo
IGH_Goo instance. If Data is not a null reference this function ALWAYS returns a GOO instance.
Remarks
This function calls a whole sh*tload of other conversion functions. IT IS SLOW.
See Also