Click or drag to resize

GH_ConvertToSurface_Primary Method

Performs a direct cast from OnSurface or GH_Surface. Data is not quaranteed to be duplicated. If data is of type GH_Surface, then trim curves are ignored.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static bool ToSurface_Primary(
	Object data,
	ref Surface rc
)

Parameters

data
Type: SystemObject
Data to convert
rc
Type: Surface

Return Value

Type: Boolean
An OnSurface instance if successful, or Nothing on failure.
See Also