Click or drag to resize

GH_ConvertCommonObjectToByteArray Method

Convert a RhinoCommon object into a compressed byte-array using safe Rhino 5.0 OpenNurbs serialization.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static byte[] CommonObjectToByteArray(
	CommonObject data
)

Parameters

data
Type: CommonObject
Object to serialize.

Return Value

Type: Byte
A byte array representing the object or null on failure.
See Also