Click or drag to resize

GH_ConvertToSafeRhinoCommonObject Method

Convert RhinoCommon types that are dangerous to use out of context (BrepFace, BrepEdge, etc.) into safe types (Brep, Curve, etc.).

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static Object ToSafeRhinoCommonObject(
	Object data
)

Parameters

data
Type: SystemObject
Data to convert.

Return Value

Type: Object
Safe data.
See Also