Click or drag to resize

GH_ConvertParseExpression Method

Attempts to parse an expression.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GH_Variant ParseExpression(
	string exp,
	bool recursive
)

Parameters

exp
Type: SystemString
Expression to parse.
recursive
Type: SystemBoolean
If True, and the result of the expression is a String, the result is parsed again until the result is no longer a String or until the expression fails.

Return Value

Type: GH_Variant
The result of the (recursive) expression.
See Also