Click or drag to resize

GH_ConvertGetSurfaceFromDocument Method

Harvest a surface object from a Rhino document.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static bool GetSurfaceFromDocument(
	RhinoDoc doc,
	Guid id,
	out Surface srf
)

Parameters

doc
Type: RhinoDoc
Document to search.
id
Type: SystemGuid
ID of surface object.
srf
Type: Surface
Surface result.

Return Value

Type: Boolean
True on success, false on failure.
See Also