Click or drag to resize

GH_ConvertToVariableName Method

Extract the implied variable name from a compound string. A string is considered compound if it contains a parenthesis pair with at least one character within the brackets.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static string ToVariableName(
	string compound
)

Parameters

compound
Type: SystemString
String to parse.

Return Value

Type: String
The variable name as extracted or the original compound if no name was implied.
See Also