Click or drag to resize

GH_ConvertToPlural Method

Apply english rules to convert a noun into its plural form. This algorithm is not water-tight as it will not handle any irregular cases.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static string ToPlural(
	string singular
)

Parameters

singular
Type: SystemString
Singular form of noun.

Return Value

Type: String
Plural form of noun.
See Also