Click or drag to resize

GH_ConvertToRectangle Method

Convert a floating point GDI rectangle structure to an integer rounded rectangle. Use this method for any and all GUI conversions as the specific rounding scheme used here avoids pixel jitter.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static Rectangle ToRectangle(
	RectangleF in
)

Parameters

in
Type: System.DrawingRectangleF
RectangleF to convert.

Return Value

Type: Rectangle
Integer accuracy rectangle.
See Also