Click or drag to resize

GH_SolutionPhase Enumeration

The Phase flags are used to track object states during solutions.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public enum GH_SolutionPhase
Members
  Member nameValueDescription
Blank0 There is no data available in this object. This object will be solved next time a solution begins.
Collecting1 This object is currently in the process of collecting data
Collected2 This object has finished collecting all data and is ready for computation.
Computing3 This object is currently in the process of computing new data
Computed4 This object has successfully completed data computation and it will be skipped in the next solution unless it expires in the meantime. This is the final step in a successful solution cycle.
Failed10 This object has failed to successfully complete the data computation stage. A new attempt at solving it will be made when the next solution starts. This is the final step in an unsuccessful solution cycle.
See Also