Click or drag to resize

GH_UndoOperation Enumeration

Enumerates all possible types of undo operation.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public enum GH_UndoOperation
Members
  Member nameValueDescription
ClearUndoStack0 The stack with all undo records has been cleared.
ClearRedoStack1 The stack with all redo records has been cleared. This always happens when a new undo record is added.
RecordAdded2 A new undo record is added to the list. There will be a ClearRedoStack event after this one.
RecordRemoved3 A specific record has been deleted. This is not a typical operation and is usually due to user intervention. Removal can occur from both the undo and the redo stack.
Undo4 An undo operation was successfully completed. This means a record has been moved from the undo stack to the redo stack.
Redo5 A redo operation was successfully completed. This means a record has been moved from the redo stack back onto the undo stack. This does not count as a RecordAdded operation.
See Also