Click or drag to resize

GH_DataComparison Enumeration

Enumerates all possible Data Matching algorithms for Components.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public enum GH_DataComparison
Members
  Member nameValueDescription
ShortestList0 Matches data in all lists until the shortest list runs dry. This flag will omit data entries if lists have a different length
LongestList1 Matches data in all lists until the longest list runs dry. This is the default behaviour
CrossReference2 Matches data in all lists in all possible combinations. Careful, since this might results in stupendous amounts of data
See Also