Click or drag to resize

GH_ProcessStep Enumeration

Enumerates all possible solution states in which the document can be.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public enum GH_ProcessStep
Members
  Member nameValueDescription
PreProcess0 The document is ready for a new solution
Process1 The document is currently calculating a new solution, no changes are allowed during this phase
PostProcess2 The document has completed a solution, and nothing has changed since.
Aborted3 The last solution has been aborted before it reached completion.
See Also