Click or drag to resize

GH_ObjectSpecies Enumeration

Contains all object species.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
[FlagsAttribute]
public enum GH_ObjectSpecies
Members
  Member nameValueDescription
none0 Indicates no object type
doc_object1 Represents any object that implements IGH_DocumentObject
parameter16 Indicates classes that implement IGH_Param
component32 Indicates classes that implement IGH_Component
group64 Indicates classes of type GH_Group
wire128 Currently this is not yet an object type.
grip_in256 Represents an input grip.
grip_out512 Represents an output grip.
grip768 Represents an input or output grip.
balloon1024 Represents an attribute balloon.
any4294967295 Indicates all object types.
See Also