Click or drag to resize

GH_DocumentContext Enumeration

Enumerates all possible (de)activation contexts for documents.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public enum GH_DocumentContext
Members
  Member nameValueDescription
Unknown0 Specifies unknown context. This should never be used.
None1 Specifies unset state. This is only used for documents that have never been in a context.
Open2 Indicates the document was created anew from a file.
Close3 Indicates the document has been unloaded from memory.
Loaded4 Indicates the document has been loaded into the Canvas.
Unloaded5 Indicates the document has been unloaded from the Canvas.
Lock6 Indicates the document has been locked. This is only possible for nested documents.
Unlock7 Indicates the document has been unlocked. This is only possible for nested documents.
See Also