Click or drag to resize

GH_ParamHashFields Enumeration

Enumerates all accepted fields for hashing parameter data.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
[FlagsAttribute]
public enum GH_ParamHashFields
Members
  Member nameValueDescription
None0 Represents a blank hash.
Input1 Input parameters are taken into account.
Output2 Output parameters are taken into account.
InputAndOutput3 Input and output parameters are taken into account.
InstanceId4 Parameter instance ID is taken into account.
NickName8 Parameter nickname is taken into account.
Access16 Parameter access (item, list, tree) is taken into account.
TypeId32 Parameter type code is taken into account.
PersistentData64 Parameter persistent data is taken into account.
Expression128 Parameter Expression is taken into account.
TypeHint256 Parameter typehint is taken into account.
Sources65536 Parameter source IDs are taken into account.
Recipients131072 Parameter recipient IDs are taken into account.
SourcesAndRecipients196608 Parameter sources and recipients are taken into account.
SerialData16777216 Parameter serialization byte array is taken into account.
See Also