Click or drag to resize

GH_Exposure Enumeration

Lists the different kinds of GUI exposure an object can have.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
[FlagsAttribute]
public enum GH_Exposure
Members
  Member nameValueDescription
hidden-1 Do not expose the object anywhere. This is useful for legacy components.
primary2 Expose the object in the first section on the toolbar.
secondary4 Expose the object in the second section on the toolbar.
tertiary8 Expose the object in the third section on the toolbar.
quarternary16 Expose the object in the fourth section on the toolbar.
quinary32 Expose the object in the fifth section on the toolbar.
senary64 Expose the object in the sixth section on the toolbar.
septenary128 Expose the object in the seventh section on the toolbar.
octonary256 Expose the object in the eighth section on the toolbar.
last256 This exposure will be the last subcategory available.
obscure65536 Mark the object as obscure. Use this option for components which are unlikely to be used often. You must combine obscure with one of the other flags (except hidden). Objects which are marked as Obscure will be the first to disappear when a ribbon resizes and they will always appear at the end of a panel.
See Also