ArcCurve class
Represent arcs and circles.
ArcCurve.IsCircle returns True if the curve is a complete circle.
Details:
an ArcCurve is a sub-curve of a circle, with a constant speed parameterization. The parameterization is an affine linear reparameterization of the underlying arc m_arc onto the domain m_t.
A valid ArcCurve has Radius()>0 and 0<AngleRadians()<=2*PI and a strictly increasing Domain.
Derived Classes:
Namespace: Rhino.Geometry
ArcCurve: references
keyboard_arrow_down
Constructors (11)
keyboard_arrow_down
Properties (28)
keyboard_arrow_down
Methods (263)