Description:

Constructs a curve from a set of control-point locations.

Syntax:
public static Curve CreateControlPointCurve(
IEnumerable<Point3d> points,
int degree
)
Parameters:
  • points
  • Type: IEnumerable<Point3d>
  • Control points.
  • degree
  • Type: int
  • Degree of curve. The number of control points must be at least degree+1.
Returns:
Type: Curve
Available since:
5.0

Description:

Constructs a control-point of degree=3 (or less).

Syntax:
public static Curve CreateControlPointCurve(
IEnumerable<Point3d> points
)
Parameters:
  • points
  • Type: IEnumerable<Point3d>
  • Control points of curve.
Returns:
Type: Curve
Available since:
5.0

/
/
/
CreateControlPointCurve

CreateControlPointCurve method

Class:  Rhino.Geometry.Curve

Nothing found