Description:

Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve.

Syntax:
public double NormalizedLengthParameters(
double s,
double absoluteTolerance,
double fractionalTolerance,
Interval subdomain
)
Parameters:
  • s
  • Type: double
  • Array of normalized arc length parameters. E.g., 0 = start of curve, 1/2 = midpoint of curve, 1 = end of curve.
  • absoluteTolerance
  • Type: double
  • If absoluteTolerance > 0, then the difference between (s[i+1]-s[i])*curve_length and the length of the curve segment from t[i] to t[i+1] will be <= absoluteTolerance.
  • fractionalTolerance
  • Type: double
  • Desired fractional precision for each segment. fabs("true" length - actual length)/(actual length) <= fractionalTolerance.
  • subdomain
  • Type: Interval
  • The calculation is performed on the specified sub-domain of the curve. A 0.0 s value corresponds to sub-domain->Min() and a 1.0 s value corresponds to sub-domain->Max().
Returns:
Type: double
If successful, array of curve parameters such that the length of the curve from its start to t[i] is s[i]*curve_length. Null on failure.
Available since:
5.0

Description:

Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve.

Syntax:
public double NormalizedLengthParameters(
double s,
double absoluteTolerance,
double fractionalTolerance
)
Parameters:
  • s
  • Type: double
  • Array of normalized arc length parameters. E.g., 0 = start of curve, 1/2 = midpoint of curve, 1 = end of curve.
  • absoluteTolerance
  • Type: double
  • If absoluteTolerance > 0, then the difference between (s[i+1]-s[i])*curve_length and the length of the curve segment from t[i] to t[i+1] will be <= absoluteTolerance.
  • fractionalTolerance
  • Type: double
  • Desired fractional precision for each segment. fabs("true" length - actual length)/(actual length) <= fractionalTolerance.
Returns:
Type: double
If successful, array of curve parameters such that the length of the curve from its start to t[i] is s[i]*curve_length. Null on failure.
Available since:
5.0

Description:

Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve. A fractional tolerance of 1e-8 is used in this version of the function.

Syntax:
public double NormalizedLengthParameters(
double s,
double absoluteTolerance,
Interval subdomain
)
Parameters:
  • s
  • Type: double
  • Array of normalized arc length parameters. E.g., 0 = start of curve, 1/2 = midpoint of curve, 1 = end of curve.
  • absoluteTolerance
  • Type: double
  • If absoluteTolerance > 0, then the difference between (s[i+1]-s[i])*curve_length and the length of the curve segment from t[i] to t[i+1] will be <= absoluteTolerance.
  • subdomain
  • Type: Interval
  • The calculation is performed on the specified sub-domain of the curve. A 0.0 s value corresponds to sub-domain->Min() and a 1.0 s value corresponds to sub-domain->Max().
Returns:
Type: double
If successful, array of curve parameters such that the length of the curve from its start to t[i] is s[i]*curve_length. Null on failure.
Available since:
5.0

Description:

Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve. A fractional tolerance of 1e-8 is used in this version of the function.

Syntax:
public double NormalizedLengthParameters(
double s,
double absoluteTolerance
)
Parameters:
  • s
  • Type: double
  • Array of normalized arc length parameters. E.g., 0 = start of curve, 1/2 = midpoint of curve, 1 = end of curve.
  • absoluteTolerance
  • Type: double
  • If absoluteTolerance > 0, then the difference between (s[i+1]-s[i])*curve_length and the length of the curve segment from t[i] to t[i+1] will be <= absoluteTolerance.
Returns:
Type: double
If successful, array of curve parameters such that the length of the curve from its start to t[i] is s[i]*curve_length. Null on failure.
Available since:
5.0

/
/
/
NormalizedLengthParameters

NormalizedLengthParameters method

Class:  Rhino.Geometry.Curve

Nothing found