Description:

Rebuild a curve with a specific point count.

Syntax:
public NurbsCurve Rebuild(
int pointCount,
int degree,
bool preserveTangents
)
Parameters:
  • pointCount
  • Type: int
  • Number of control points in the rebuild curve.
  • degree
  • Type: int
  • Degree of curve. Valid values are between and including 1 and 11.
  • preserveTangents
  • Type: bool
  • If true, the end tangents of the input curve will be preserved.
Returns:
A NURBS curve on success or None on failure.
Available since:
5.0

Rebuild method

Class:  Rhino.Geometry.Curve

Nothing found