Description:

Computes the fillet arc for a curve filleting operation.

Syntax:
public static Arc CreateFillet(
Curve curve0,
Curve curve1,
double radius,
double t0Base,
double t1Base
)
Parameters:
  • curve0
  • Type: Curve
  • First curve to fillet.
  • curve1
  • Type: Curve
  • Second curve to fillet.
  • radius
  • Type: double
  • Fillet radius.
  • t0Base
  • Type: double
  • Parameter on curve0 where the fillet ought to start (approximately).
  • t1Base
  • Type: double
  • Parameter on curve1 where the fillet ought to end (approximately).
Returns:
Type: Arc
The fillet arc on success, or Arc.Unset on failure.
Available since:
5.0

CreateFillet method

Class:  Rhino.Geometry.Curve

Nothing found