Description:
Creates a surface between two surfaces, with a fixed rail curve on the first surface.
Syntax:
public bool FilletSurfaceToRail(
BrepFace faceWithCurve,
BrepFace secondFace,
double u1,
double v1,
int railDegree,
int arcDegree,
IEnumerable<double> arcSliders,
int numBezierSrfs,
bool extend,
FilletSurfaceSplitType split_type,
double tolerance,
List<Brep> out_fillets,
List<Brep> out_breps0,
List<Brep> out_breps1,
out double fitResults
)
BrepFace faceWithCurve,
BrepFace secondFace,
double u1,
double v1,
int railDegree,
int arcDegree,
IEnumerable<double> arcSliders,
int numBezierSrfs,
bool extend,
FilletSurfaceSplitType split_type,
double tolerance,
List<Brep> out_fillets,
List<Brep> out_breps0,
List<Brep> out_breps1,
out double fitResults
)
Parameters:
- faceWithCurve
- Type: BrepFace
- The first face on which the curve exists
- secondFace
- Type: BrepFace
- The second face
- u1
- Type: double
- A parameter in the u direction of the second face at the side you want to keep after filleting.
- v1
- Type: double
- A parameter in the v direction of the second face at the side you want to keep after filleting.
- railDegree
- Type: int
- Desired fillet degree (3 or 5) in the u-direction, along the rails
- arcDegree
- Type: int
- esired fillet degree (2, 3, 4, or 5) in the v-direction, along the fillet arcs.If 2, then the surface is rational in v
- arcSliders
- Type: IEnumerable<double>
- Array of 2 sliders to shape the fillet in the arc direction, used for arcDegree = 3, 4, or 5; input { 0.0, 0.0 } to ignore [0] (-1 to 1) slides tangent arms from base (-1) to theoretical(1) [1] (-1 to 1) slides inner CV(s) from base (-1) to theoretical(1)
- numBezierSrfs
- Type: int
- If >0, this indicates the number of equally-spaced fillet surfaces to be output in the rail direction, each surface Bézier in u.
- extend
- Type: bool
- If true, then when one input surface is longer than the other, the fillet surface is extended to the input surface edges.
- split_type
- Type: FilletSurfaceSplitType
- The split type
- tolerance
- Type: double
- The tolerance. In in doubt, the the document's absolute tolerance.
- out_fillets
- Type: List<Brep>
- The results of the fillet calculation.
- out_breps0
- Type: List<Brep>
- The trim or split results of the Brep owned by faceWithCurve.
- out_breps1
- Type: List<Brep>
- The trim or split results of the Brep owned by pFace1.
- fitResults
- Type: double
- array of doubles indicating fitting results: [0] max 3d point deviation along surface 0 [1] max 3d point deviation along surface 1 [2] max angle deviation along surface 0 (in degrees) [3] max angle deviation along surface 1 (in degrees) [4] max angle deviation between Bézier surfaces(in degrees) [5] max curvature difference between Bézier surfaces
Returns:
Type: bool
True if successful, False otherwise.
Remarks:
The trim or split input Breps are in OutBreps0, and OutBreps1. If the input faces are from the same Brep, nothing will be added to OutBreps1.If you specified a split type of RhinoFilletSurfaceSplitType::Nothing, then nothing will be added to either OutBreps0 or OutBreps1.
Available since:
8.0