Description:

Local minimization for point on a curve with tangent perpendicular to N.

Syntax:
public bool FindLocalInflection(
Vector3d N,
Interval subDomain,
double seed,
out double curveParameter,
out double angleError
)
Parameters:
  • N
  • Type: Vector3d
  • This vector and the curve tangent define a plane. In this plane, there is a vector V perpendicular to the tangent.
  • subDomain
  • Type: Interval
  • Subdomain of of curve to evaluate. This must not be empty.
  • seed
  • Type: double
  • A seed parameter, which must be included in the subdomain.
  • curveParameter
  • Type: double
  • The parameter on the curve if successful, RhinoMath.UnsetValue if unsuccessful.
  • angleError
  • Type: double
  • The measure, in radians, of the angle between N and V. The angle will be zero when the result is an inflection.
Returns:
Type: bool
True if the minimization succeeds, regardless of angle_error, False if unsuccessful.
Remarks:
The algorithm minimizes the square of the dot product of N with the curve tangent. It is possible that the result will not be close to zero.
Available since:
8.0

/
/
/
FindLocalInflection

FindLocalInflection method

Class:  Rhino.Geometry.Curve

Nothing found