Description:
Finds a curve by offsetting an existing curve normal to a surface. The caller is responsible for ensuring that the curve lies on the input surface.
Parameters:
- surface
- Type: Surface
- Surface from which normals are calculated.
- height
- Type: double
- Offset distance.
Returns:
Type: Curve
Curve offset normal to the surface, if successful, None otherwise. The offset curve is interpolated through a small number of points so if the surface is irregular or complicated, the result will not be a very accurate offset.
Available since:
5.0