Description:

Search for a location on the curve, near seedParmameter, that is perpendicular to a test point.

Syntax:
public bool GetLocalPerpPoint(
Point3d testPoint,
double seedParmameter,
Interval subDomain,
out double curveParameter
)
Parameters:
  • testPoint
  • Type: Point3d
  • The test point.
  • seedParmameter
  • Type: double
  • A "seed" parameter on the curve.
  • subDomain
  • Type: Interval
  • The sub-domain of the curve to search.
  • curveParameter
  • Type: double
  • The parameter value at the perpendicular point
Returns:
Type: bool
True if a solution is found, False otherwise.
Available since:
6.0

Description:

Search for a location on the curve, near seedParmameter, that is perpendicular to a test point.

Syntax:
public bool GetLocalPerpPoint(
Point3d testPoint,
double seedParmameter,
out double curveParameter
)
Parameters:
  • testPoint
  • Type: Point3d
  • The test point.
  • seedParmameter
  • Type: double
  • A "seed" parameter on the curve.
  • curveParameter
  • Type: double
  • The parameter value at the perpendicular point
Returns:
Type: bool
True if a solution is found, False otherwise.
Available since:
6.0

/
/
/
GetLocalPerpPoint

GetLocalPerpPoint method

Class:  Rhino.Geometry.Curve

Nothing found