Description:

Finds the parameter of the point on a curve that is closest to testPoint. If the maximumDistance parameter is > 0, then only points whose distance to the given point is <= maximumDistance will be returned. Using a positive value of maximumDistance can substantially speed up the search.

Syntax:
public bool ClosestPoint(
Point3d testPoint,
out double t,
double maximumDistance
)
Parameters:
  • testPoint
  • Type: Point3d
  • Point to project.
  • t
  • Type: double
  • parameter of local closest point returned here.
  • maximumDistance
  • Type: double
  • The maximum allowed distance. Past this distance, the search is given up and False is returned. Use 0 to turn off this parameter.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Finds parameter of the point on a curve that is closest to testPoint. If the maximumDistance parameter is > 0, then only points whose distance to the given point is <= maximumDistance will be returned. Using a positive value of maximumDistance can substantially speed up the search.

Syntax:
public bool ClosestPoint(
Point3d testPoint,
out double t
)
Parameters:
  • testPoint
  • Type: Point3d
  • Point to search from.
  • t
  • Type: double
  • Parameter of local closest point.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

ClosestPoint method

Class:  Rhino.Geometry.Curve

Nothing found