Description:

Creates curves between two open or closed input curves. Use sample points method to make curves compatible. This is how the algorithm works: Divides the two curves into an equal number of points, finds the midpoint between the corresponding points on the curves and interpolates the tween curve through those points. There is no matching of curves direction. Caller must match input curves direction before calling the function.

Syntax:
public static Curve[] CreateTweenCurvesWithSampling(
Curve curve0,
Curve curve1,
int numCurves,
int numSamples,
double tolerance
)
Parameters:
  • curve0
  • Type: Curve
  • The first, or starting, curve.
  • curve1
  • Type: Curve
  • The second, or ending, curve.
  • numCurves
  • Type: int
  • Number of tween curves to create.
  • numSamples
  • Type: int
  • Number of sample points along input curves.
  • tolerance
  • Type: double
  • The tolerance. When in doubt, use the document's model absolute tolerance.
Returns:
Type: Curve[]
>An array of tween curves. This array can be empty.
Available since:
6.0

Description:

Creates curves between two open or closed input curves. Use sample points method to make curves compatible. This is how the algorithm works: Divides the two curves into an equal number of points, finds the midpoint between the corresponding points on the curves and interpolates the tween curve through those points. There is no matching of curves direction. Caller must match input curves direction before calling the function.

Syntax:
public static Curve[] CreateTweenCurvesWithSampling(
Curve curve0,
Curve curve1,
int numCurves,
int numSamples
)
deprecated in 6.0
obsolete: Use version that takes tolerance as input
Parameters:
  • curve0
  • Type: Curve
  • The first, or starting, curve.
  • curve1
  • Type: Curve
  • The second, or ending, curve.
  • numCurves
  • Type: int
  • Number of tween curves to create.
  • numSamples
  • Type: int
  • Number of sample points along input curves.
Returns:
Type: Curve[]
>An array of tween curves. This array can be empty.
Available since:
5.2

/
/
/
CreateTweenCurvesWithSampling

CreateTweenCurvesWithSampling method

Class:  Rhino.Geometry.Curve

Nothing found