Description:

Computes the relationship between a point and a closed curve region. This curve must be closed or the return value will be Unset.

Syntax:
public PointContainment Contains(
Point3d testPoint,
Plane plane,
double tolerance
)
Parameters:
  • testPoint
  • Type: Point3d
  • Point to test.
  • plane
  • Type: Plane
  • Plane in which to compare point and region.
  • tolerance
  • Type: double
  • Tolerance to use during comparison.
Returns:
Relationship between point and curve region.
Available since:
5.0

Description:

Computes the relationship between a point and a closed curve region. This curve must be closed or the return value will be Unset.

Syntax:
public PointContainment Contains(
Point3d testPoint,
Plane plane
)
deprecated in 6.0
obsolete: Use version that takes a tolerance
Parameters:
  • testPoint
  • Type: Point3d
  • Point to test.
  • plane
  • Type: Plane
  • Plane in which to compare point and region.
Returns:
Relationship between point and curve region.
Available since:
5.0

Description:

Computes the relationship between a point and a closed curve region. This curve must be closed or the return value will be Unset. Both curve and point are projected to the World XY plane.

Syntax:
public PointContainment Contains(
Point3d testPoint
)
deprecated in 6.0
obsolete: Use version that takes a tolerance
Parameters:
  • testPoint
  • Type: Point3d
  • Point to test.
Returns:
Relationship between point and curve region.
Available since:
5.0

Contains method

Class:  Rhino.Geometry.Curve

Nothing found