Description:

Creates outline curves created from a text string. The functionality is similar to what you find in Rhino's TextObject command or TextEntity.Explode() in RhinoCommon.

Syntax:
public static Curve[] CreateTextOutlines(
string text,
string font,
double textHeight,
int textStyle,
bool closeLoops,
Plane plane,
double smallCapsScale,
double tolerance
)
Parameters:
  • text
  • Type: string
  • The text from which to create outline curves.
  • font
  • Type: string
  • The text font. If the font does not exist on the system. Rhino will use a substitute with similar properties.
  • textHeight
  • Type: double
  • The text height.
  • textStyle
  • Type: int
  • The font style. The font style can be any number of the following: 0 - Normal, 1 - Bold, 2 - Italic
  • closeLoops
  • Type: bool
  • Set this value to True when dealing with normal fonts and when you expect closed loops. You may want to set this to False when specifying a single-stroke font where you don't want closed loops.
  • plane
  • Type: Plane
  • The plane on which the outline curves will lie.
  • smallCapsScale
  • Type: double
  • Displays lower-case letters as small caps. Set the relative text size to a percentage of the normal text.
  • tolerance
  • Type: double
  • The tolerance for the operation.
Returns:
Type: Curve[]
An array containing one or more curves if successful.
Available since:
6.0

/
/
/
CreateTextOutlines

CreateTextOutlines method

Class:  Rhino.Geometry.Curve

Nothing found