Description:

Calculates the boolean union of two or more closed, planar curves. Note, curves must be co-planar.

Syntax:
public static Curve[] CreateBooleanUnion(
IEnumerable<Curve> curves,
double tolerance
)
Parameters:
  • curves
  • Type: IEnumerable<Curve>
  • The co-planar curves to union.
Returns:
Type: Curve[]
Result curves on success, empty array if no union could be calculated.
Available since:
6.0

Description:

Calculates the boolean union of two or more closed, planar curves. Note, curves must be co-planar.

Syntax:
public static Curve[] CreateBooleanUnion(
IEnumerable<Curve> curves
)
deprecated in 6.0
obsolete: Use version that takes tolerance as input
Parameters:
  • curves
  • Type: IEnumerable<Curve>
  • The co-planar curves to union.
Returns:
Type: Curve[]
Result curves on success, empty array if no union could be calculated.
Available since:
5.0

/
/
/
CreateBooleanUnion

CreateBooleanUnion method

Class:  Rhino.Geometry.Curve

Nothing found