Description:

Gets the length of the curve with a fractional tolerance of 1.0e-8.

Syntax:
public double GetLength()
Returns:
Type: double
The length of the curve on success, or zero on failure.
Available since:
5.0

Description:

Get the length of a sub-section of the curve.

Syntax:
public double GetLength(
double fractionalTolerance,
Interval subdomain
)
Parameters:
  • fractionalTolerance
  • Type: double
  • Desired fractional precision. fabs(("exact" length from start to t) - arc_length)/arc_length <= fractionalTolerance.
  • subdomain
  • Type: Interval
  • The calculation is performed on the specified sub-domain of the curve (must be non-decreasing).
Returns:
Type: double
The length of the sub-curve on success, or zero on failure.
Available since:
5.0

Description:

Get the length of the curve.

Syntax:
public double GetLength(
double fractionalTolerance
)
Parameters:
  • fractionalTolerance
  • Type: double
  • Desired fractional precision. fabs(("exact" length from start to t) - arc_length)/arc_length <= fractionalTolerance.
Returns:
Type: double
The length of the curve on success, or zero on failure.
Available since:
5.0

Description:

Get the length of a sub-section of the curve with a fractional tolerance of 1e-8.

Syntax:
public double GetLength(
Interval subdomain
)
Parameters:
  • subdomain
  • Type: Interval
  • The calculation is performed on the specified sub-domain of the curve (must be non-decreasing).
Returns:
Type: double
The length of the sub-curve on success, or zero on failure.
Available since:
5.0

GetLength method

Class:  Rhino.Geometry.Curve

Nothing found