Description:

Several types of Curve can have the form of a polyline including a degree 1 NurbsCurve, a PolylineCurve, and a PolyCurve all of whose segments are some form of polyline. IsPolyline tests a curve to see if it can be represented as a polyline.

Syntax:
public bool TryGetPolyline(
out Polyline polyline,
out double parameters
)
Parameters:
  • polyline
  • Type: Polyline
  • If True is returned, then the polyline form is returned here.
  • parameters
  • Type: double
  • if True is returned, then the parameters of the polyline points are returned here.
Returns:
Type: bool
True if this curve can be represented as a polyline; otherwise, false.
Available since:
5.0

Description:

Several types of Curve can have the form of a polyline including a degree 1 NurbsCurve, a PolylineCurve, and a PolyCurve all of whose segments are some form of polyline. IsPolyline tests a curve to see if it can be represented as a polyline.

Syntax:
public bool TryGetPolyline(
out Polyline polyline
)
Parameters:
  • polyline
  • Type: Polyline
  • If True is returned, then the polyline form is returned here.
Returns:
Type: bool
True if this curve can be represented as a polyline; otherwise, false.
Available since:
5.0

/
/
/
TryGetPolyline

TryGetPolyline method

Class:  Rhino.Geometry.Curve

Nothing found