Description:

Returns the parameter values of all local extrema. Parameter values are in increasing order so consecutive extrema define an interval on which each component of the curve is monotone. Note, non-periodic curves always return the end points.

Syntax:
public double ExtremeParameters(
Vector3d direction
)
Parameters:
  • direction
  • Type: Vector3d
  • The direction in which to perform the calculation.
Returns:
Type: double
The parameter values of all local extrema.
Available since:
6.0

/
/
/
ExtremeParameters

ExtremeParameters method

Class:  Rhino.Geometry.Curve

Nothing found