menu
RhinoCommon API
search
search
V8
arrow_drop_down
filter_list
arrow_drop_down
new_releases
wb_sunny
RhinoCommon documentation has a new look. The old site can still be found
here
.
Close
Description:
Extends a curve by a line until it intersects a collection of objects.
Syntax:
public
Curve
ExtendByLine(
CurveEnd
side
,
IEnumerable<GeometryBase>
geometry
)
Parameters:
side
Type:
CurveEnd
The end of the curve to extend.
geometry
Type:
System.Collections.Generic.IEnumerable<GeometryBase>
A collection of objects. Allowable object types are Curve, Surface, Brep.
Returns:
Type:
Curve
New extended curve result on success, None on failure.
Available since:
5.0
home
/
Rhino.Geometry
/
Curve
/
ExtendByLine
ExtendByLine method
Class:
Rhino.Geometry.Curve
Nothing found