Description:

Converts a curve into polycurve consisting of arc segments. Sections of the input curves that are nearly straight are converted to straight-line segments.

Syntax:
public PolyCurve ToArcsAndLines(
double tolerance,
double angleTolerance,
double minimumLength,
double maximumLength
)
Parameters:
  • tolerance
  • Type: double
  • The tolerance. This is the maximum deviation from arc midpoints to the curve. When in doubt, use the document's model space absolute tolerance.
  • angleTolerance
  • Type: double
  • The angle tolerance in radians. This is the maximum deviation of the arc end directions from the curve direction. When in doubt, use the document's model space angle tolerance.
  • minimumLength
  • Type: double
  • The minimum segment length.
  • maximumLength
  • Type: double
  • The maximum segment length.
Returns:
Type: PolyCurve
PolyCurve on success, None on error.
Available since:
6.0

/
/
/
ToArcsAndLines

ToArcsAndLines method

Class:  Rhino.Geometry.Curve

Nothing found