Description:

Determines whether two coplanar simple closed curves are disjoint or intersect; otherwise, if the regions have a containment relationship, discovers which curve encloses the other.

Syntax:
public static RegionContainment PlanarClosedCurveRelationship(
Curve curveA,
Curve curveB,
Plane testPlane,
double tolerance
)
Parameters:
  • curveA
  • Type: Curve
  • A first curve.
  • curveB
  • Type: Curve
  • A second curve.
  • testPlane
  • Type: Plane
  • A plane.
  • tolerance
  • Type: double
  • A tolerance value.
Returns:
A value indicating the relationship between the first and the second curve.
Available since:
5.0

/
/
/
PlanarClosedCurveRelationship

PlanarClosedCurveRelationship method

Class:  Rhino.Geometry.Curve

Nothing found