Description:

Projects this curve onto a mesh.

Syntax:
public Curve PullToMesh(
Mesh mesh,
double tolerance,
bool loose
)
Parameters:
  • mesh
  • Type: Mesh
  • Mesh to project onto.
  • tolerance
  • Type: double
  • Input tolerance. When in doubt, the the document's model absolute tolerance.
  • loose
  • Type: bool
  • If true, the curve's edit points are pulled back to the mesh. If any edit point misses the mesh, the curve will not be created.
Returns:
Type: Curve
A curve if success, or None on failure.
Available since:
8.17

Description:

Makes a polyline approximation of the curve and gets the closest point on the mesh for each point on the curve. Then it "connects the points" so that you have a polyline on the mesh.

Syntax:
public PolylineCurve PullToMesh(
Mesh mesh,
double tolerance
)
Parameters:
  • mesh
  • Type: Mesh
  • Mesh to project onto.
  • tolerance
  • Type: double
  • Input tolerance. When in doubt, the the document's model absolute tolerance.
Returns:
A curve if success, or None on failure.
Available since:
5.0

PullToMesh method

Class:  Rhino.Geometry.Curve

Nothing found