Description:

Shortens a curve by a given length

Syntax:
public Curve Trim(
CurveEnd side,
double length
)
Returns:
Type: Curve
Trimmed curve if successful, None on failure.
Available since:
5.1

Description:

Removes portions of the curve outside the specified interval.

Syntax:
public Curve Trim(
double t0,
double t1
)
Parameters:
  • t0
  • Type: double
  • Start of the trimming interval. Portions of the curve before curve(t0) are removed.
  • t1
  • Type: double
  • End of the trimming interval. Portions of the curve after curve(t1) are removed.
Returns:
Type: Curve
Trimmed portion of this curve is successful, None on failure.
Available since:
5.0

Description:

Removes portions of the curve outside the specified interval.

Syntax:
public Curve Trim(
Interval domain
)
Parameters:
  • domain
  • Type: Interval
  • Trimming interval. Portions of the curve before curve(domain[0]) and after curve(domain[1]) are removed.
Returns:
Type: Curve
Trimmed curve if successful, None on failure.
Available since:
5.0

Nothing found