Description:

Splits a curve into pieces using a polysurface.

Syntax:
public Curve[] Split(
Brep cutter,
double tolerance,
double angleToleranceRadians
)
Parameters:
  • cutter
  • Type: Brep
  • A cutting surface or polysurface.
  • tolerance
  • Type: double
  • A tolerance for computing intersections.
  • angleToleranceRadians
  • Type: double
Returns:
Type: Curve[]
An array of curves. This array can be empty.
Available since:
6.0

Description:

Splits a curve into pieces using a polysurface.

Syntax:
public Curve[] Split(
Brep cutter,
double tolerance
)
deprecated in 6.0
obsolete: Use version that takes an angle tolerance
Parameters:
  • cutter
  • Type: Brep
  • A cutting surface or polysurface.
  • tolerance
  • Type: double
  • A tolerance for computing intersections.
Returns:
Type: Curve[]
An array of curves. This array can be empty.
Available since:
5.0

Description:

Splits (divides) the curve at the specified parameter. The parameter must be in the interior of the curve's domain.

Syntax:
public Curve[] Split(
double t
)
Parameters:
  • t
  • Type: double
  • Parameter to split the curve at in the interval returned by Domain().
Returns:
Type: Curve[]
Two curves on success, None on failure.
Available since:
5.0

Description:

Splits (divides) the curve at a series of specified parameters. The parameter must be in the interior of the curve domain.

Syntax:
public Curve[] Split(
IEnumerable<double> t
)
Parameters:
  • t
  • Type: IEnumerable<double>
  • Parameters to split the curve at in the interval returned by Domain().
Returns:
Type: Curve[]
Multiple curves on success, None on failure.
Available since:
5.0

Description:

Splits a curve into pieces using a surface.

Syntax:
public Curve[] Split(
Surface cutter,
double tolerance,
double angleToleranceRadians
)
Parameters:
  • cutter
  • Type: Surface
  • A cutting surface or polysurface.
  • tolerance
  • Type: double
  • A tolerance for computing intersections.
  • angleToleranceRadians
  • Type: double
Returns:
Type: Curve[]
An array of curves. This array can be empty.
Available since:
6.0

Description:

Splits a curve into pieces using a surface.

Syntax:
public Curve[] Split(
Surface cutter,
double tolerance
)
deprecated in 6.0
obsolete: Use version that takes an angle tolerance
Parameters:
  • cutter
  • Type: Surface
  • A cutting surface or polysurface.
  • tolerance
  • Type: double
  • A tolerance for computing intersections.
Returns:
Type: Curve[]
An array of curves. This array can be empty.
Available since:
5.0

Split method

Class:  Rhino.Geometry.Curve

Nothing found